Default Input Method: El problema de los acentos en Ubuntu

Pues gracias al tico pude resolver el misterio de los acentos en Ubuntu: El input method tiene que ser SCIM para que las letras con tilde aparezcan.

En teoria, deberia ser facil solucionar el problema simplmente usando SCIM (Smart Common Input Method) como default, pero la realidad es que… ya esta en default!! Que quiere decir esto? que se supone que el sistema esta debidamente configurado para que todas las aplicaciones usen SCIM, pero ninguna respeta esa configuracion. Revisando las variables de ambiente me encuentro que:

QT_IM_MODULE=scim
GTK_IM_MODULE=scim
XMODIFIERS=@im=SCIM

Es decir, todo en orden. Sin embargo, al iniciar aplicaciones como OpenOffice, KEdit o Gedit e incluso Eclipse, tengo que cambiarles el input method a SCIM de forma manual. Segun lei, se prefiere este tipo de comportamiento porque, de otra forma, cada aplicacion mandaria llamar a SCIM cada que se inicializa, haciendo que el proceso tarde mas, dando la sensacion de que SCIM hace mas lenta la maquina. El unico problema es Firefox, ya que no permite cambiar el input method, por lo que, aqui en la maquina del laboratorio, no puedo escribir correctamente 🙁

No he revisado el problema en la EeePC. Hoy en la noche veo que puedo hacer. En la laptop, el mapa de caracteres no reconoce la tecla de Windows, y eso provoco que tuviera que cambiar la ModKey de DWM de Mod4Mask (Windows key) a Mod1Mask (Alt), lo cual no seria tan malo si no usara tanto Emacs.

Yo creo que definitivamente voy a terminar instalando algo diferente en la laptop. Le traigo ganas a Nexenta, pero quien sabe que tal este. Si no, algo como Slackware. Si de plano no me da tiempo, voy a terminar con Fedora 9, lo cual no me agrada en lo mas minimo. En todo caso, el panda me recomienda Debian Unstable. Tengo sentimientos encontrados respecto a esa distribucion, puesto que use Sarge cuando todavia era unstable y no fue del todo una experiencia placentera (aunque si fue muy ilustrativo). Igual le damos otra oportunidad.

8 thoughts on “Default Input Method: El problema de los acentos en Ubuntu”

  1. No entiendo ni lo mas mínimo de lo que hablas, pero qué bueno que escribes sobre todas esas cosas porque eso hace que me de la curiosidad 😉

  2. [quote comment=””][/quote]
    ejejjejejjeje cuando te pones escribir sobre sistemas y ese tipo de cosas se me hace q escribes en japones por q no entiendo nada, suerte y sigue escribiendo por q checo tu blog todos los dias y ya lleva un tiempo q no escribes nada, ja nee!!

  3. Muchas gracias por el aviso, en cuanto pueda hacer arrancar Ubuntu de nuevo en mi computadora te digo cómo me fue. X(

  4. [quote comment=””]Muchas gracias por el aviso, en cuanto pueda hacer arrancar Ubuntu de nuevo en mi computadora te digo cómo me fue. X([/quote]

    Chécale a ver qué tal. En Fedora no tengo problemas para escribir en español (como puede notarse), y hasta tengo en mini script los comandos para no estar tecleando cada vez lo mismo. Los puse en /usr/local/bin

    jpkeyb: setxkbmap -model jp106 -layout jp
    spkeyb: setxkbmap -model jp106 -layout latam

  5. Hoy cumplo dos semanas sin tocar windows, pero venga q tengo el mismo problema que tU y eso q configurE mi mAquina en español, pero como no suelo escribir bien muy seguido y ando de vacaciones no sE si el problema lo tenIa desde q instalE ubuntu o desde que instalE todo el paquete para japonEs. Quiz´a ah´i est´a el problema(asi se ve cuando intento poner acentos, de momento no me queda otra sino agarrarme de que las mayUsculas no llevan acentos xD). Eso de ordernar usar SCIM me funciona pero para Opera no me funciona, no he intentado en Firefox pero dices q es lo mismo asi q te creo. Por cierto te sabes algo asi como alt+164 para poner las ñ’s en linux?

    Si puedes respondeme por mail si sabes algo mas sobre los mEndigos acentos, en dos semanas vuelvo a clases y quisiera q no me ande dando lata Ubuntu para hacer tareas, por q en windows todavia ni le pongo office, perdi el disco, suponog q para no meterme en broncas le metere openoffice ahi tbn.
    Por cierto tambien he tenido un monton de problemas con mi tarjeta de video ATI 9550, no logro hacer que reproduzca mp4, si tengo el acelerador de graficos activado totem reproduce muy mal los avis, VLC lo corre mucho mejor, pero ala hora de poner pantalla completa se ve feo, la opcion es deshabilitar el acelerador y reiniciar apra ver videos se ve muy bonito pero para youtube se ve asqueroso. En fin creo q no encuentro mas que problemas ultimamente en Ubuntu.

    Asi q deuevo, una manita me caeria muy bien, por cierto q planeo andar de monbusho por alla dentro de dos años.

  6. Por si alguno cae por aquí. no pongan eliminar teclas muertas ni sun dead keys. pongan teclado estándar 105 teclas internacional, latinoamerica, predeterminado. Si tienen latinoamerica en la configuracion de teclado pongan el de España, borren la de latinoamerica, y vuelvan a hacer lo mismo pero al contrario.

  7. SOLUCIONADO:
    Borrar el fichero es_ES o el que sea, yo borré todos, del directorio ~/.xinput.d, el directorio lo dejé vacío.

    ~ quiere decir el home de tu usuario: /home/tuusuario/.xinput.d

    Para novatos: Abrir el menú Aplicaciones – Accesorios – Terminal
    y teclear:
    rm ~/.xinput.d/*

    el carácter ~ se consigue con la tecla ALT GR + 4 (el 4 del teclado normal), y luego pulsar espacio.

    Todo lo cogí de https://bugs.launchpad.net/ubuntu/+source/emacs-snapshot/+bug/199915
    Así que gracias a Diego Sevilla Ruiz.

    Saludos.

  8. Hola, soy nuevo en ubuntu y me gustaria que me echaras una mano con scim, no logro que escriba japones en OpenOffice mas si escribe en gedit, evolution, bueno en firefox ya tu lo has dicho.gracias

Leave a Reply

Your email address will not be published. Required fields are marked *